Tag

Razer Lycosa

Browsing

Update 10/14/10: I decided that I am no longer going to use the Lycosa. Even with the new model (MT10) that Razer sent me I still experience the same issues with the keys randomly dying and/or ghost sticking on me. I’ve got the latest drivers for Windows 7 64bit and nothing helps. I’ve come to the conclusion that it’s not the keyboard itself but the horribly crappy drivers for the Lycosa. I’ll still purchase other Razer products but as far as their keyboard line goes: hell no.

A few weeks I wrote about how I was disappointed with Razer and their Lycosa. I was holding off on buying a new keyboard when I ended up receiving a message from cultofrazer on my Youtube account. Hilmar ‘Razer|Water’ Hahn, a Product Evangelist at Razer, handles the Razer Lycosa and contacted me after seeing my blog post about the issues I’ve been having. He wanted to make it up to me and renew the relationship. As a result he wanted to send me a replacement Razer Lycosa and send me a free Razer Orca as he thought it would be perfect for me.

Needless to say I was extremely grateful to see that a Razer employee has gone out of his way to ensure that I am once again a satisfied customer! This positive response from them definitely guarantees that I will no doubt continue using and purchasing Razer products. In fact I’m finally going to replace my poor, dirty, worn out Goliathis for a new Goliathus Fragged Control Edition surface pad… Now if only they’d release their damn Onza controller that I’ve been waiting on for eons!

Last year I was on the lookout for a new keyboard and having already been using Razer products (Razer Abyssus and a Razer Goliathus), I decided to take a gander at their keyboards.

I went with the Razer Lycosa keyboard. I wanted something with laptop-style keys that would be quieter and of course the backlight was a plus. Unfortunately for me, I didn’t read up on any reviews on this product at all. I just went blind into the purchase as I was already familiar with Razer.

Razer Lycosa

The first few couple of months were fine; I used the keyboard on a daily basis for hours at a time. After awhile though I noticed that the occasional time a key would not respond (eg: the letter ‘g’ would not respond) and unplugging the USB cord would ‘reset’ it. This happened so seldom that I never thought anything of it. However, after awhile it turned into more than just a key here and there. Eventually the touch screen to change light settings (WSAD, all keys lit, off) would randomly stop responding and various keys would be ‘stuck’ despite not having even touched them.

It has gotten to the point where I would unplug the USB cord for my keyboard every few hours. A couple of months ago I finally researched a bit on the product and found various articles that this was a common problem with the Lycosa. Lycosa’s with serials that started at MT0803, MT0802, MT0801, and MT07 were those that were affected however Razer stated that “were limited to a small batch of customers” and since the problem was ‘so small’ no recall was necessary. My Lycosa starts with an MT09 serial number and apparently I should not be affected–but I am!

I finally decided to contact Razer last night as I was tired of putting up with the poor reliability of the Lycosa. I received a reply within a few hours asking for more details on the purchase. And finally around 10PM last night I received a response that they would not offer me an RMA on the Lycosa due to my purchase having only a 90 day warranty on it from November 2009 to January 2010. WHAT?!

The main article I read on the issue was from Tomshardware.comRazer Responds to Lycosa KB Issue

“Frick also mentioned that the problem was small enough that there wasn’t any recall performed, and that customers with affected serial numbers can get their boards replaced free of charge.”

So just because my serial isn’t specifically listed as affected yet those with MT09 keyboards DO have this issue, I’m screwed no matter what. I just think it’s poor that Razer knows of this issue yet has done nothing about it in the three years it’s actually been present. The sad thing is that the MT09’s are obviously affected because looking around online will yield tons of posts about the MT09 being affected just as well. I think that they really should have immediately taken my keyboard for an RMA despite the serial being MT09 and the warranty being up–especially when they’ve even admitted to the problem and stated that they would replace the boards free of charge.

I was really looking forward to continuing on being a loyal Razer customer. I’ve been waiting for the Razer Onza to release and after this issue, I’m not even sure if I want to continue using Razer’s products. Between the issue STILL being present and Razer failing to replace the obviously defective product, I’m already looking at picking up a Logitech Illuminated keyboard and a Xtrac pads for future mouse/surface pads.

Logitech Illuminated Keyboard